Есть ответ 👍

Составить программу, решающую следующую : вы покупаете товар, и у вас имеются монеты номиналом 1, 2, 5, 10 рублей. наберите необходимую сумму товара в n рублей так, чтобы она состояла из минимального количества монет. язык паскаль

258
470
Посмотреть ответы 2

Ответы на вопрос:

zlu4ka11
4,6(60 оценок)

Program noname; var a,b,c,d,e; begin readln(a); b: =a div 10; a: =a-b; c: =a div 5; a: =a-c; d: =a div 2; a: =a-d; e: =a; writeln('десяток: ',b); writeln('пятёрок: ',c); writeln('двоек: ',d); writeln('единиц: ',e); writeln('всего монет: '(b+c+d+e)); end.
Vitalikprofi
4,5(100 оценок)

число бит информации определяется как log 2 (n/n') где n - число возможных вариантов до получения информации, а n' - после. т.е. нам надо посчитать сколько существует комбинаций из 11 подбрасываний всего (2^11 = 2048) и сколько таких, где 4 орла идут подряд (таких очевидно 8 - 11110000000, 01111000000, 00111100000, 00011110000, 00001111000, 00000111100, 00000011110, 00000001111). имеем log 2 (2048 / 8) = log 2 (2^11 / 2^3) = log 2 (2^8) = 8 бит

 

ответ   8   бит

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS