Есть ответ 👍

Написать программу(паскаль). с пояснениями, желательно. нужно с for. найти сумму всех n-значных чисел, кратных k.(1 < (или равно) n< (или равно)4).

227
248
Посмотреть ответы 3

Ответы на вопрос:

Ckorpid
4,4(68 оценок)

var

  k, n, summ, i, max, min: integer;

begin

  write('n = '); readln(n);

  write('k = '); readln(k);

  max : = 9;

  min : = 1;

  for i : = 2 to n do

  begin

      max : = max * 10 + 9;

      min : = min * 10;

  end;

  for i : = min to max do

      if i mod k = 0 then

          summ : = summ + i;

  writeln('сумма = ', summ);

end.

texet1024
4,5(39 оценок)

program sada;

var k,n,res,i: integer;

      temp: string;

begin

res: =0;

readln(k);

temp: ='';

for i: =1 to n do

temp: =temp+'9';

n: =strtoint(temp);

for i: =1 to n do begin

if (i mod k = 0) then res: =res+i;

end;

writeln(res);

end.

 

 

p.s. программа написана на pascalabc


Джон   бернес ли, британский ученый, изобретатель всемирной паутины третий ответ

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS