Есть ответ 👍

Нужно написать программу на паскале для перевода натурального числа из двоичной системы в десятичную (в двоичном числе не более 10 цифр).

182
278
Посмотреть ответы 1

Ответы на вопрос:


const nn=50; vara: array [1..nn,1..nn] of integer; i,j,m,n: integer; begin  write('введите n: ');   readln(n);   write('введите m: ');   readln(m);   for i: = 1 to n do      for j: = 1 to m do          readln(a[i,j]);   for i: = 1 to n do      for j: = 1 to m do          if a[i,j] mod 2 =0 then a[i,j]: =a[i,j] div 2;   for i: = 1 to n do  begin      for j: = 1 to m do          write(a[i,j],' ');       writeln;   end;   end.

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS