Есть ответ 👍

Составить программу,которая возводит в степень дробь

250
313
Посмотреть ответы 2

Ответы на вопрос:


// pascalabc.net 3.0, сборка 1150 от 22.01.2016 begin   var a,b,sgn: integer;   var aa,bb,ap,bp: biginteger;   var s: string: ='';   write('введите числитель и знаменатель дроби: ');   read(a,b);   var n: =readinteger(' показатель степени: ');   if n=0 then writelnformat('({0}/{1})^0 = 1',a,b)   else       if (a=0) and (b< > 0) then writelnformat('(0/{0})^{1} = 0',b,n)       else begin           if a*b< 0 then s: ='-';           aa: =abs(a); bb: =abs(b); ap: =1; bp: =1;           if n> 0 then               for var i: =1 to n do begin ap*=aa; bp*=bb end           else               for var i: =1 to -n do begin ap*=bb; bp*=aa end;           if bp=1 then               writelnformat('({0}/{1})^{2} = {3}{4}',a,b,n,s,ap)           else               writelnformat('({0}/{1})^{2} = {3}{4}/{5}',a,b,n,s,ap,bp)           end end. тестовые примеры: введите числитель и знаменатель дроби: 1 23 показатель степени: 5 (1/23)^5 = 1/6436343 введите числитель и знаменатель дроби: 1 6 показатель степени: -4 (1/6)^-4 = 1296 введите числитель и знаменатель дроби: -3 31 показатель степени: 11 (-3/31)^11 = -177147/25408476896404831 введите числитель и знаменатель дроби: -17 -125 показатель степени: 4 (-17/-125)^4 = 83521/244140625 введите числитель и знаменатель дроби: -15 27 показатель степени: 0 (-15/27)^0 = 1 введите числитель и знаменатель дроби: 0 3 показатель степени: 2 (0/3)^2 = 0 введите числитель и знаменатель дроби: 2 0 показатель степени: 3 (2/0)^3 = 8/0 введите числитель и знаменатель дроби: 0 0 показатель степени: 3 (0/0)^3 = 0/0

25

Объяснение:11001=1*2∧4+1*2∧3+0*2∧2+0*2∧1+1*2∧0=25

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS