Есть ответ 👍

№1. необходимо составить программу расчета конечной суммы и сравнения полученного результата с контрольным значением. число членов суммы вводится с клавиатуры. s=1+3+5+7++(2n-1), контрольное значение n в квадрате.

211
484
Посмотреть ответы 2

Ответы на вопрос:

66546654
4,6(48 оценок)

Var n,s,i: integer; begin write('n='); readln(n); s: =0; for i: =1 to n do s: =s+2*i-1; writeln('s=',s,'   n^2=',n*n); end.

#include < iostream> #include < iomanip> #include < ctime> int main() {       setlocale(lc_all, "russian");       const int n = 5;       int matrix[n][n];       int a[(n*n) / 2], b[(n*n)/2];       int k = 0;       srand(time(null));       for (int i = 0; i < n; i++)       {             std: : cout < < std: : endl;             for (int j = 0; j < n; j++)             {                   matrix[i][j] = rand() % 100;                   std: : cout < < std: : setw(3) < <   matrix[i][j] < < " ";             }       }       for (int i = 0; i < n; i++)             for (int j = 0; j < n; j++)                   if (i > = j)                   {                         a[k] = matrix[i][j];                         k++;                   }       std: : cout < < std: : endl;       std: : cout < < "массив, содержащий элементы, лежащие на главной диагонали и ниже ее: " < < std: : endl;       for (int i = 0; i < k; i++)             std: : cout < < a[i] < < " ";       k = 0;       std: : cout < < std: : endl;       for(int i=0; i< n; i++)             for (int j = n - i-1; j < n; j++)             {                   b[k] = matrix[i][j];                   k++;             }       std: : cout < < "массив, содержащий элементы, лежащие на побочной диагонали и ниже ее: " < < std: : endl;       for (int i = 0; i < k; i++)             std: : cout < < b[i] < < " ";       std: : cout < < std: : endl;       system("pause"); }

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS