Есть ответ 👍

Дан текстовый файл. составьте программу, которая считывает текст из файла, вычисляет количество слов в каждой строке. вставьте в конце каждой строки количество слов и записать в новом файле.

191
389
Посмотреть ответы 2

Ответы на вопрос:


Var  s           : string;   finish,k,i : longint; begin  assign(input,'input.txt'); reset(input);   assign(output,'output.txt'); rewrite(output);   finish: =0;   while(finish=0) do { если finish будет < > 0 то программа      перестанет читать текст}    begin      writeln('читать? если да, то 0 если нет, то 1');       readln(finish);       k: =0;       if finish=0        then begin                readln(s);                 for i: =1 to length(s) do                  if s[i]=' '                    then inc(k);               end        else exit;       inc(k);       writeln(k);     end; end.
Maxxxx123
4,6(97 оценок)

Разбираем число n на цифры, а затем собираем в нужном порядке: var n,n1,n2,n3,x: integer; begin write('n = '); readln(n); n1: =n div 100; n2: =n div 10 mod 10; n3: =n mod 10; x: =n3*100+n2*10+n1; writeln('x = ',x); end. пример 1: n = 25x = 520пример 2: n = 823x = 328

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS