Есть ответ 👍

Составьте программу которая осуществляет ввод в массив с клавиатуры 7 целых чисел и заменяет отрицательные на -1

123
266
Посмотреть ответы 2

Ответы на вопрос:


Var a: array[1..7] of integer; i: integer; n1: real; begin writeln('введите 7 целых чисел'); for i: =1 to 7 do begin repeat read(n1); if (n1< > round(n1)) then  writeln('необходимо целое число'); until (n1=round(n1)); a[i]: =round(n1); end; for i: =1 to 7 do begin if a[i]< 0 then a[i]: =-1; end; writeln('полученный массив: '); for i: =1 to 7 do write(a[i]: 5); writeln(''); end.

Впорядке убывания количества найденных  страниц: а г б в

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS