Есть ответ 👍

Нужно составить программу, которая сможет вывести число, месяц и день недели, которые наступят через k дней, начиная с первого января 2008 года. напомним, что это был вторник. язык : паскаль. целое число k (0 < = k < = 1000) пример: входа: | выхода: 0 | tuesday, 01.01 5 | sunday, 06.01

173
472
Посмотреть ответы 2

Ответы на вопрос:

Era383727
4,7(53 оценок)

// я , невероятно не люблю изобретать велосипеды //поэтому воспользуемся уже встроенным типом datatime //pascal abc.net версия 2.2 сборка 790 uses system; var k: integer; startsys: datetime; //сабж m,d: string; begin; readln(k); startsys: =startsys.addyears(2007); //добавляет года к старту, отсчёт от 1 startsys: =startsys.adddays(k); //добавляет кол-во дней //тип сам определяет високосный год или нет writeln(startsys.dayofweek,', ',startsys.day,'.',startsys.month); //вывод end.

8856582432526385535857465482

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS