Есть ответ 👍

Дана строка. среди символов строки встречаются цифры. написать программу, вычисляющую сумму всех цифр строки.

280
416
Посмотреть ответы 3

Ответы на вопрос:

сим666
4,8(92 оценок)

fasm

 

org 100h

mov si, string cld

my_loop: lodsb cmp al, 0 jz loop_exit cmp al, '0' jb my_loop cmp al, '9' ja my_loop sub al, '0' add bx, ax jmp my_loop

loop_exit: push -1 mov ax, bxloop_push: xor dx, dx div [d] push dx cmp ax, 0 jne loop_push mov ah, 2h

print: pop dx cmp dx, -1 je exit add dl, '0' int 21h jmp print

exit: mov ah, 01h int 21h ret

d dw 10string db "1", 0

 

fpc

 

var s : string; i, c : integer; begin readln (s); c : = 0; for i : = 1 to length (s) do if (s[i] in ['0'..'9']) then inc (c, ord (s[i]) - ord ('0')); writeln (c); end.

 

 


например на ассемблере в синтаксисе fasm под дос:

 

org 100hmov si,stringcldmov cx,16xor ax,axmov ah,02hxor bx,bxm1: mov dl,[si]push cxmov cx,10mov di,numm2: cmp dl,[di]jnz m3; int 21hsub dl,30hadd bl,dlm3: inc diloop m2pop cxinc siloop m1xor ax,axmov al,blmov bx,10xor cx,cxm4: xor dx,dxdiv bxpush dxinc cxcmp ax,0jnz m4m5: pop dxadd dx,30hmov ah,2hint 21hdec cxjnz m5mov ah,01hint 21hmov ax,4c00hint 21hstring db "1nr112t3brj9me18",0num db "0123456789",0

 

для строки "1nr112t3brj9me18" сумма будет равна 26.


Ссожсжшажгазгажгаосомл

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS