Есть ответ 👍

Составьте алгоритм и напишите программу для того чтобы выяснить является ли введённое шестизначное число счастливым суперсчастливым или обыкновенным. шестизначное число называют счастливым если сумма первых трёх его цифр равна сумме трёх последних цифр. число будет называться суперсчастливым если оно во-первых счастливое а во-вторых сумма первых трёх его чисел равна 11 или 22

188
364
Посмотреть ответы 2

Ответы на вопрос:


Var n: longint; c1,c2: byte; s: boolean; begin s: =false readln(n); c1: =(n mod 10)+((n div 10) mod 10)+((n div 100) mod 10); c2: =((n div 1000) mod 10) + ((n div 10000) mod 10) + ((n div 100000) mod 10); if c1=c2 then s: =true; if s and ((c2=11) or (c2=22)) then writeln('supershastlivoe') else if s then writeln('shaslivoe') else writeln('prostoe'); end.
Эрайз
4,5(62 оценок)

program p;

var a,b: integer;

begin

a: =1;

repeat begin

writeln('введите число: ');

readln(b); if b< 0 then a: =a*b;

until b=0; writeln('ответ: ',a);

readln; end.

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS