Есть ответ 👍

Автомат принимает трёхзначное число, вычисляет сумму двух старших разрядов (сотен и десятков), а также сумму двух младших разрядов( десятков и единиц). затем эти суммы выводятся на экран в порядке возрастания(без пробелов). напишите программу, которая моделирует работу автомата

297
368
Посмотреть ответы 2

Ответы на вопрос:

Anasteija
4,5(15 оценок)

{с клавиатуры вводится число до тех пор, пока не будет введено 3-х значное, сумма первых двух цифр записывается в a, сумма десятков и единиц - в b. сравнивается какое из них больше и выводится в порядке возрастания} uses crt; var a,c,b: integer; begin     clrscr;       repeat             writeln('input 3-x znachoe');             readln(b);         until (b> =100)and(b< =999); a: =b div 100+(b div 10)mod 10; c: =(b div 10)mod 10+b mod 10;       if a< c then           writeln(a,c) else           writeln(c,a); readkey; end.

Оценки в журнале. таблица умножения. список товаров и стоимость. правила по языку.

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS