Есть ответ 👍

Требовалось написать программу, при выполнении которой с клавиатуры считывается натуральное число n, не превосходящее 10^9, и выводится количество цифр этого числа. программист торопился и написал программу неправильно. var n: longint; sum: integer; begin readln(n); sum : = 1; while n > 1 do begin n : = n div 10; sum : = sum + 1; end; writeln(sum); end. последовательно выполните следующее. 1. напишите, что выведет эта программа при вводе числа 938? 2. укажите одно число, для которого программа будет работать верно. 3. найдите все ошибки в этой программе (их может быть одна или несколько). укажите все строки (одну или более), содержащие ошибки, и для каждой такой строки правильный вариант. обратите внимание, что требуется найти ошибки в имеющейся программе, а не написать свою, возможно, использующую другой алгоритм решения. исправление ошибки должно затрагивать только строку, в которой находится ошибка.

169
436
Посмотреть ответы 2

Ответы на вопрос:


Эта программа присваивает значение переменной n, потом присваивает переменной sum значение 1, за  тем в случае пока n больше 1,   выделяет целое число при делении значения переменной n на 10 и    присваивает это значение переменной   n (повторяет эту операцию пока n больше 1), когда значение переменной n не больше  1 программа печатает на экран полученное в последнем цикле значение  переменной sum. ответ:   1) выведет 4 2) 10 3) sum : = 0;   while n > = 1 do

A∧B A∨B B∨¬A

Объяснение:

Первое логическое выражение(A∧B) это конъюнкция(И), которая выполняется, только когда оба условия истинны. Только первое утверждение имеет такую конструкцию(И).

Второе логическое выражение(A∨B) это дизъюнкция(ИЛИ), которая выполняется, когда хотя бы одно из условий истинно. Это второе утверждение.

Третье отличается от второго тем, что имеет знак "¬" (НЕ), который отрицает утверждение, что студент едет в метро (отрицает А). Третьему утверждению соответствует логическое выражение B∨¬A.

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS