Есть ответ 👍

100 .напишите программу перевода числа из восьмеричной системы счисления в двоичную. оформить в паскале.

255
401
Посмотреть ответы 2

Ответы на вопрос:


Предполагается, что восьмеричное число записано, как символьная строка, поскольку максимальная разрядность не была оговорена в . const   m: array['0'..'7'] of string=           ('000','001','010','011','100','101','110','111');   m1: array['1'..'7'] of string=           ('1','10','11','100','101','110','111'); var   s8,s2: string;   i: integer; begin   write('введите восьмеричное число: '); readln(s8);   s2: =m1[s8[1]];   for i: =2 to length(s8) do s2: =s2+m[s8[i]];   writeln('в двоичной системе: ',s2) end. тестовое решение: введите восьмеричное число: 360721 в двоичной системе: 11110000111010001
444477
4,7(92 оценок)

Один воробей улетел точно. имеется 3 вороны и 5 воробьев. предположим, что все вороны улетели. у нас получится, что улетел 3 птицы, а надо4.

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS