Есть ответ 👍

Написать программу поиска любого элемента в массиве. для уточнения - на языке программирования, для программы паскаль.

161
465
Посмотреть ответы 3

Ответы на вопрос:

Floki23
4,5(80 оценок)

Поиска индекса элемента по заданному значению или поиска значения по заданному индексу? напишу решение для обоих случаев. 1. поиск элемента по заданному индексу var n: longint; m: array[1..1000] of longint; begin writeln('введите индекс элемента массива'); read(n); writeln('элемент под номером ',n,' равен ',m[n]); end. 2. поиск индекса по заданному значению в массиве: var n,i: longint; m: array[1..1000] of longint; begin read(n); i: =1; while m[i]< > n do i: =i+1; writeln(m[i]); end.
BRB987
4,4(52 оценок)

Program pm; uses crt; var x: array[1..1000] of integer; k,a,b,i: integer; begin clrscr; write('введите кол-во элементов массива: '); read(k); writeln; write('введите диапазон значений заполнения(a-начальное значение, b-конечное): '); repeat read(a,b); until a< =b; writeln; randomize; for i: =1 to k do x[i]: =random(b-a+1)+a; writeln('ваш массив: '); for i: =1 to k do write(x[i]: 5); writeln; write('введите элемент поиска: '); read(b); a: =0; for i: =1 to k do if x[i]=b then a: =i; if a> 0 then writeln('элемент со значением ',b,' имеет индекс ',a) else writeln('элемента не существует! '); readkey; end.
123451529
4,5(66 оценок)

Иогрнрнргргршршргшдщ

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS