Есть ответ 👍

Если сумма налога исчисляется в рублях и копейках, то налоговая служба округляет её до ближайшего рубля (до 50 копеек - с недостатком, свыше 50 копеек (включая 50) - с избытком). используйте компьютер, чтобы ввести точную сумму налога и вывести, сколько следует уплатить. написать программу

213
359
Посмотреть ответы 3

Ответы на вопрос:


Var a,b: real; begin readln(a); if  frac(a)> 0.5 then   b: =int(a)+1 else b: =int(a); writeln(b); end.
koblovalv
4,5(72 оценок)

Var  s,r,p: real; begin readln(s); r: =frac(s);   //функция frac возвращает дробную часть if r> 0.5 then   p: =int(s)+1 //функция int возвращает целую   часть else  p: =int(s); writeln(p); end.

Если ты правильно переписал, то 20. y: = 10; x: = 10 + y; то есть x: = 10 + 10 = 20; y: = y - 1; то есть y: = 10 - 1 = 9; но это никак не влияет на x, т.к. эта операция идет уже после выполнения вычисления переменной!

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS