Есть ответ 👍

Дан массив, состоящий из целых чисел. напишите программу, которая в данном массиве определит количество элементов, у которых два соседних и, при этом, оба соседних элемента меньше данного. входные данные сначала задано число n — количество элементов в массиве (1n100). далее через пробел записаны n чисел — элементы массива. массив состоит из целых чисел. выходные данные необходимо вывести количество элементов массива, у которых два соседа и которые при этом строго больше обоих своих соседей. примеры входные данные 5 1 2 3 4 5 выходные данные 0 входные данные 5 1 5 1 5 1 выходные данные 2

229
409
Посмотреть ответы 2

Ответы на вопрос:


Var i,num,s: integer;       arr: array of integer; begin   readln(num);   setlength(arr,num);   for i: =0 to num-1 do begin       read(arr[i]);       if i> 1 then begin           if (arr[i-2]< arr[i-1]) and (arr[i]< arr[i-1]) then s+=1;       end;   end;   writeln('',s); end.

0,2 гб 209715,2 кб 214748364,8 б 1717986918,4 бит

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS