Есть ответ 👍

(30 ! ): составить программу на языке паскаль для решения следующей : задать одномерный массив случайным образом, элементы которого принадлежат промежутку [-30; 40]; найти количество элементов массива, принадлежащих промежутку [-10; 25).

121
169
Посмотреть ответы 2

Ответы на вопрос:


Const     n = 3; var   i,s: integer;   a: array[1..n] of integer; begin   s: =0;   for i: =1 to n do     begin       a[i]: =random(71)-30;       if (a[i]> =-10) and (a[i]< 25) then s: =s+1;     end;   writeln('полученный массив: ');   for i: =1 to n do     write('a[': 4,i,']=',a[i]);     writeln;   write('промежутку [-10; 25) принадлежат ',s,' элемент(ов)'); end.

#Pp, Sp - периметр и площадь прямоугольника, туда вставляешь эти данные

# Pk Sk соответственно периметр и площадь квадрата

Pp =

Sp =

Pk =

Sk =

if Pp < Pk:

P = Pk / Pp

print('Різниця периметру квадрата та прямокутника дорівнює ', P)

else:

P = Pp / Pk

print('Різниця периметру квадрата та прямокутника дорівнює ', P)

if Sp < Sk:

S = Sk / Sp

print('Різниця площі квадрата та прямокутника дорівнює ', S)

else:

S = Sp / Sk

print('Різниця алощі квадрата та прямокутника дорівнює ', S)

Реши свою проблему, спроси otvet5GPT

  • Быстро
    Мгновенный ответ на твой вопрос
  • Точно
    Бот обладает знаниями во всех сферах
  • Бесплатно
    Задай вопрос и получи ответ бесплатно

Популярно: Информатика

Caktus Image

Есть вопросы?

  • Как otvet5GPT работает?

    otvet5GPT использует большую языковую модель вместе с базой данных GPT для обеспечения высококачественных образовательных результатов. otvet5GPT действует как доступный академический ресурс вне класса.
  • Сколько это стоит?

    Проект находиться на стадии тестирования и все услуги бесплатны.
  • Могу ли я использовать otvet5GPT в школе?

    Конечно! Нейросеть может помочь вам делать конспекты лекций, придумывать идеи в классе и многое другое!
  • В чем отличия от ChatGPT?

    otvet5GPT черпает академические источники из собственной базы данных и предназначен специально для студентов. otvet5GPT также адаптируется к вашему стилю письма, предоставляя ряд образовательных инструментов, предназначенных для улучшения обучения.

Подпишись на наш телеграмм канал

GTP TOP NEWS